re = /^(https?:\/\/[^\/,]+)(\/+[^,]+)/m
str = 'https://community.domain.tld/register?to=3662%2354564894861351532416dzda#%frfgrzfz,categorie,dateAcces,,,
https://community.domain.tld/register?tests,categorie,dateAcces,,,
https://community.domain.tld/register,categorie,dateAcces,,,
https://community.domain.tld/ce/register,categorie,dateAcces,,,
https://community.domain.tld/ce/ce/register,categorie,dateAcces,,,
https://community.domain.tld,categorie,dateAcces,,,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end