$re = '`<img src="(.*?)" border="0" alt=""/>`m';
$str = 'Мне нужно заменить, например,
<img src="AAA11111111" border="0" alt=""/>
на
<IMG src=\\"AAA1\\"><s>[img]</s>AAA1<e>[/img]</e></IMG><e>[/url]</e></URL>
, где AAA1 — URL произвольной длины.
Что мне использовать, чтобы это сделать? Обработке подлежит 38 миллионов символов.';
$subst = "<IMG src=\"$1\"><s>[img]</s>AAA1<e>[/img]</e></IMG><e>[/url]</e></URL>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;