# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img src=\"(.*?)\" border=\"0\" alt=\"\"/>"
test_str = ("Мне нужно заменить, например, \n"
"<img src=\"AAA11111111\" border=\"0\" alt=\"\"/>\n"
"на\n"
"<IMG src=\\\"AAA1\\\"><s>[img]</s>AAA1<e>[/img]</e></IMG><e>[/url]</e></URL>\n\n"
", где AAA1 — URL произвольной длины.\n\n"
"Что мне использовать, чтобы это сделать? Обработке подлежит 38 миллионов символов.")
subst = "<IMG src=\"$1\"><s>[img]</s>AAA1<e>[/img]</e></IMG><e>[/url]</e></URL>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.