import Foundation
let pattern = #"<img src="(.*?)" border="0" alt=""/>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Мне нужно заменить, например,
<img src="AAA11111111" border="0" alt=""/>
на
<IMG src=\"AAA1\"><s>[img]</s>AAA1<e>[/img]</e></IMG><e>[/url]</e></URL>
, где AAA1 — URL произвольной длины.
Что мне использовать, чтобы это сделать? Обработке подлежит 38 миллионов символов.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<IMG src="$1"><s>[img]</s>AAA1<e>[/img]</e></IMG><e>[/url]</e></URL>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)