#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b[2-9TJQKA]+\b"
Local $sString = "643TJAKQ" & @CRLF & _
"" & @CRLF & _
"72MAJTQ" & @CRLF & _
"" & @CRLF & _
"1246AKJQ" & @CRLF & _
"" & @CRLF & _
"AKT432"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")