$re = '/\b[2-9TJQKA]+\b/';
$str = '643TJAKQ
72MAJTQ
1246AKJQ
AKT432';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);