using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_[0-9a-z]{24}(*SKIP)(*FAIL)|[a-z]+(?:_[a-z]+)*";
string input = @"hello word some_stuff other_stuff_607eea770b6d00003d001579 something
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}