package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`_[0-9a-z]{24}(*SKIP)(*FAIL)|[a-z]+(?:_[a-z]+)*`)
var str = `hello word some_stuff other_stuff_607eea770b6d00003d001579 something
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}