re = /_[0-9a-z]{24}(*SKIP)(*FAIL)|[a-z]+(?:_[a-z]+)*/
str = 'hello word some_stuff other_stuff_607eea770b6d00003d001579 something
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end