$re = '/(?:\S*\s*){4}$/';
$str = 'house, man, love, me, book, car, verbs, substantives';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);