re = /(?:\S*\s*){4}$/
str = 'house, man, love, me, book, car, verbs, substantives'
# Print the match result
str.match(re) do |match|
puts match.to_s
end