# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[1-9]\d{2}(0[1-9]|1[0-2])(0[1-9]|[12]\d|3[01])(0[1-9]|[1-4]\d|5[0-2]|99)(00[1-9]|0[1-9]\d|[1-9]\d\d)\d$/CNPJ/g;t' <<< "1870818340915"