// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^[1-9]\d{2}(0[1-9]|1[0-2])(0[1-9]|[12]\d|3[01])(0[1-9]|[1-4]\d|5[0-2]|99)(00[1-9]|0[1-9]\d|[1-9]\d\d)\d$").unwrap();
let string = "1870818340915";
let substitution = "CNPJ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}