#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
" (?=.*\b4bccf\b)" & @CRLF & _
" (?=.*\bMedia\b)" & @CRLF & _
" (.+)$" & @CRLF & _
" (?=" & @CRLF & _
" (?:" & @CRLF & _
" (?!" & @CRLF & _
" (?=.*\b4bccf\b)" & @CRLF & _
" (?=.*\bMedia\b)" & @CRLF & _
" )" & @CRLF & _
" [\s\S]" & @CRLF & _
" )*" & @CRLF & _
" \z" & @CRLF & _
" )" & @CRLF & _
"|" & @CRLF & _
"^" & @CRLF & _
" (?=.*\bLive\b)" & @CRLF & _
" (?=.*\b4bccf\b)" & @CRLF & _
" (?=.*\bmy\b)" & @CRLF & _
" (.+)$" & @CRLF & _
" (?=" & @CRLF & _
" (?:" & @CRLF & _
" (?!" & @CRLF & _
" (?=.*\bLive\b)" & @CRLF & _
" (?=.*\b4bccf\b)" & @CRLF & _
" (?=.*\bmy\b)" & @CRLF & _
" )" & @CRLF & _
" [\s\S]" & @CRLF & _
" )*" & @CRLF & _
" \z" & @CRLF & _
" )" & @CRLF & _
""
Local $sString = "blah blah blah" & @CRLF & _
"first line : "4bccf" and "Media"" & @CRLF & _
"second line : "Live" and "4bccf" and "my"" & @CRLF & _
"blah blah blah" & @CRLF & _
"first line : "4bccf" and "Media"" & @CRLF & _
"second line : "Live" and "4bccf" and "my"" & @CRLF & _
"blah blah blah" & @CRLF & _
"first line : "4bccf" and "Media"" & @CRLF & _
"blah" & @CRLF & _
"second line : "Live" and "4bccf" and "my"" & @CRLF & _
"" & @CRLF & _
"my" & @CRLF & _
"Live 4bccf" & @CRLF & _
"Media Live my" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")