import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ " (?=.*\\b4bccf\\b)\n"
+ " (?=.*\\bMedia\\b)\n"
+ " (.+)$\n"
+ " (?=\n"
+ " (?:\n"
+ " (?!\n"
+ " (?=.*\\b4bccf\\b)\n"
+ " (?=.*\\bMedia\\b)\n"
+ " )\n"
+ " [\\s\\S]\n"
+ " )*\n"
+ " \\z\n"
+ " )\n"
+ "|\n"
+ "^\n"
+ " (?=.*\\bLive\\b)\n"
+ " (?=.*\\b4bccf\\b)\n"
+ " (?=.*\\bmy\\b)\n"
+ " (.+)$\n"
+ " (?=\n"
+ " (?:\n"
+ " (?!\n"
+ " (?=.*\\bLive\\b)\n"
+ " (?=.*\\b4bccf\\b)\n"
+ " (?=.*\\bmy\\b)\n"
+ " )\n"
+ " [\\s\\S]\n"
+ " )*\n"
+ " \\z\n"
+ " )\n";
final String string = "blah blah blah\n"
+ "first line : \"4bccf\" and \"Media\"\n"
+ "second line : \"Live\" and \"4bccf\" and \"my\"\n"
+ "blah blah blah\n"
+ "first line : \"4bccf\" and \"Media\"\n"
+ "second line : \"Live\" and \"4bccf\" and \"my\"\n"
+ "blah blah blah\n"
+ "first line : \"4bccf\" and \"Media\"\n"
+ "blah\n"
+ "second line : \"Live\" and \"4bccf\" and \"my\"\n\n"
+ "my\n"
+ "Live 4bccf\n"
+ "Media Live my\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}