$re = '/^
(?=.*\b4bccf\b)
(?=.*\bMedia\b)
(.+)$
(?=
(?:
(?!
(?=.*\b4bccf\b)
(?=.*\bMedia\b)
)
[\s\S]
)*
\z
)
|
^
(?=.*\bLive\b)
(?=.*\b4bccf\b)
(?=.*\bmy\b)
(.+)$
(?=
(?:
(?!
(?=.*\bLive\b)
(?=.*\b4bccf\b)
(?=.*\bmy\b)
)
[\s\S]
)*
\z
)
/mx';
$str = 'blah blah blah
first line : "4bccf" and "Media"
second line : "Live" and "4bccf" and "my"
blah blah blah
first line : "4bccf" and "Media"
second line : "Live" and "4bccf" and "my"
blah blah blah
first line : "4bccf" and "Media"
blah
second line : "Live" and "4bccf" and "my"
my
Live 4bccf
Media Live my
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);