import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "...FS(K)-..\\/.{2}\\/..(.)\\/\\s.{2}";
final String string = "Fakturasadas : (S)FSK-69/23/GFK/12hjkhjkddddd\n\n"
+ "(S)FSK-69/23/GFK/12S Z (S)FSK-69/23/GFK/ 1 2 .)\n\n\n"
+ "FS-1195,1196,1197,2072,2073/24/GF/02, (S)FS-1195/24/GF/02, (S)FS-1196/24/GF/02, (S)FS-1197/24/GF/02, (S)FS-2072/24/GF/02, (S)FS-2073/24/GF/02 (S)FSK-69/23/GF/12\n\n"
+ "(S)FS-1499/24/GF/01 (S)FS-1500/24/GF/01";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}