# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"...FS(K)-..\/.{2}\/..(.)\/\s.{2}"
test_str = ("Fakturasadas : (S)FSK-69/23/GFK/12hjkhjkddddd\n\n"
"(S)FSK-69/23/GFK/12S Z (S)FSK-69/23/GFK/ 1 2 .)\n\n\n"
"FS-1195,1196,1197,2072,2073/24/GF/02, (S)FS-1195/24/GF/02, (S)FS-1196/24/GF/02, (S)FS-1197/24/GF/02, (S)FS-2072/24/GF/02, (S)FS-2073/24/GF/02 (S)FSK-69/23/GF/12\n\n"
"(S)FS-1499/24/GF/01 (S)FS-1500/24/GF/01")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.