# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Print\h+(#\w+)/MyPrint \1/gm;t' <<< "Print #FileNo, Tab(1); \"My Text Here\";
Print #FileNo, Tab(col); Txt;
Print #FileNo, Tab(100); Format(TheDate, \"DDMMMYYYY\") & \" \" & Variable_Name & \"Field : \" & Format(Field, \"x\")
Print #FileNo, Tab(1); Format(TheDate, \"x\") & \" - \" & TheName;
Print #FileNo, String(132, \"-\")
Print #FileNo, Tab(6); \"SOME VALUE\"; \"SOME MORE VALUES\";
Print #FileNo, Tab(100); \"First Text\"; \"Second Text\"
Print #FileNo, \"Third Text\"; \"Fourth Text\"
"