using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Print\h+(#\w+)";
string substitution = @"MyPrint \1";
string input = @"Print #FileNo, Tab(1); ""My Text Here"";
Print #FileNo, Tab(col); Txt;
Print #FileNo, Tab(100); Format(TheDate, ""DDMMMYYYY"") & "" "" & Variable_Name & ""Field : "" & Format(Field, ""x"")
Print #FileNo, Tab(1); Format(TheDate, ""x"") & "" - "" & TheName;
Print #FileNo, String(132, ""-"")
Print #FileNo, Tab(6); ""SOME VALUE""; ""SOME MORE VALUES"";
Print #FileNo, Tab(100); ""First Text""; ""Second Text""
Print #FileNo, ""Third Text""; ""Fourth Text""
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}