import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Print\\h+(#\\w+)";
final String string = "Print #FileNo, Tab(1); \"My Text Here\";\n"
+ "Print #FileNo, Tab(col); Txt;\n"
+ "Print #FileNo, Tab(100); Format(TheDate, \"DDMMMYYYY\") & \" \" & Variable_Name & \"Field : \" & Format(Field, \"x\")\n"
+ "Print #FileNo, Tab(1); Format(TheDate, \"x\") & \" - \" & TheName;\n"
+ "Print #FileNo, String(132, \"-\")\n"
+ "Print #FileNo, Tab(6); \"SOME VALUE\"; \"SOME MORE VALUES\";\n\n"
+ "Print #FileNo, Tab(100); \"First Text\"; \"Second Text\"\n"
+ "Print #FileNo, \"Third Text\"; \"Fourth Text\"\n";
final String subst = "MyPrint \\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}