$re = '/(?<!(?:\w+ *[=|] *|{{\w+ *\| *)[\w ]*)(?:(\d+(?:er)?|\d+{{er}}|{{\d+er}}) *)?(janvier|f[ée]vrier|mars|avril|mai|juin|juillet|a[ôo][ûu]t|septembre|octobre|novembre|d[ée]cembre) *(\d{3,4})/mi';
$str = ' 1er mars 2020
{{1er}} mars 2020
1{{er}} mars 2020
1 mars 2020
20 mars 2020
I don\'t want these ones:
date= 20 Mars 2025
date=20 Mars 2025
{{date|20 aout 2020}}
{{date| 20 aout 2020}}
{{date|20 aout 2020}} 1{{er}} mars 2020 {{date|20 aout 2020}} 1{{er}} mars 2020 1{{er}} mars 2020 1 mars 2020 20 mars 2020 date=20 Mars 2025
12 octobre 2012
foo=12 octobre 2012
foo = 12 octobre 2012
bar|12 octobre 2012
bar | 12 octobre 2012';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);