# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!(?:\w+ *[=|] *|{{\w+ *\| *)[\w ]*)(?:(\d+(?:er)?|\d+{{er}}|{{\d+er}}) *)?(janvier|f[ée]vrier|mars|avril|mai|juin|juillet|a[ôo][ûu]t|septembre|octobre|novembre|d[ée]cembre) *(\d{3,4})"
test_str = (" 1er mars 2020\n"
" {{1er}} mars 2020\n"
" 1{{er}} mars 2020\n"
" 1 mars 2020\n"
" 20 mars 2020\n\n\n"
"I don't want these ones:\n"
"date= 20 Mars 2025\n"
"date=20 Mars 2025\n"
"{{date|20 aout 2020}}\n"
"{{date| 20 aout 2020}}\n\n"
"{{date|20 aout 2020}} 1{{er}} mars 2020 {{date|20 aout 2020}} 1{{er}} mars 2020 1{{er}} mars 2020 1 mars 2020 20 mars 2020 date=20 Mars 2025\n"
" \n\n"
"12 octobre 2012\n"
"foo=12 octobre 2012\n"
"foo = 12 octobre 2012\n"
"bar|12 octobre 2012\n"
"bar | 12 octobre 2012")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.