import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "7Networks_([LR]H{1})_(.*)";
final String string = "7Networks_RH_SalVentAttn_Med_2\n"
+ "7Networks_RH_Limbic_OFC_1\n"
+ "7Networks_RH_Limbic_TempPole_1\n"
+ "7Networks_RH_Cont_Par_1\n"
+ "7Networks_RH_Cont_Par_2\n"
+ "7Networks_RH_Cont_PFCl_1\n"
+ "7Networks_RH_Cont_PFCl_2\n"
+ "7Networks_RH_Cont_PFCl_3\n"
+ "7Networks_RH_Cont_PFCl_4\n"
+ "7Networks_RH_Cont_Cing_1\n"
+ "7Networks_RH_Cont_PFCmp_1\n"
+ "7Networks_RH_Cont_pCun_1\n"
+ "7Networks_RH_Default_Par_1\n"
+ "7Networks_RH_Default_Temp_1\n"
+ "7Networks_RH_Default_Temp_2\n"
+ "7Networks_RH_Default_Temp_3\n"
+ "7Networks_RH_Default_PFCv_1\n"
+ "7Networks_RH_Default_PFCv_2\n"
+ "7Networks_RH_Default_PFCdPFCm_1\n"
+ "7Networks_RH_Default_PFCdPFCm_2\n"
+ "7Networks_RH_Default_PFCdPFCm_3\n"
+ "7Networks_RH_Default_pCunPCC_1\n"
+ "7Networks_RH_Default_pCunPCC_2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}