const regex = /7Networks_([LR]H{1})_(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('7Networks_([LR]H{1})_(.*)', 'gm')
const str = `7Networks_RH_SalVentAttn_Med_2
7Networks_RH_Limbic_OFC_1
7Networks_RH_Limbic_TempPole_1
7Networks_RH_Cont_Par_1
7Networks_RH_Cont_Par_2
7Networks_RH_Cont_PFCl_1
7Networks_RH_Cont_PFCl_2
7Networks_RH_Cont_PFCl_3
7Networks_RH_Cont_PFCl_4
7Networks_RH_Cont_Cing_1
7Networks_RH_Cont_PFCmp_1
7Networks_RH_Cont_pCun_1
7Networks_RH_Default_Par_1
7Networks_RH_Default_Temp_1
7Networks_RH_Default_Temp_2
7Networks_RH_Default_Temp_3
7Networks_RH_Default_PFCv_1
7Networks_RH_Default_PFCv_2
7Networks_RH_Default_PFCdPFCm_1
7Networks_RH_Default_PFCdPFCm_2
7Networks_RH_Default_PFCdPFCm_3
7Networks_RH_Default_pCunPCC_1
7Networks_RH_Default_pCunPCC_2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}