re = /7Networks_([LR]H{1})_(.*)/m
str = '7Networks_RH_SalVentAttn_Med_2
7Networks_RH_Limbic_OFC_1
7Networks_RH_Limbic_TempPole_1
7Networks_RH_Cont_Par_1
7Networks_RH_Cont_Par_2
7Networks_RH_Cont_PFCl_1
7Networks_RH_Cont_PFCl_2
7Networks_RH_Cont_PFCl_3
7Networks_RH_Cont_PFCl_4
7Networks_RH_Cont_Cing_1
7Networks_RH_Cont_PFCmp_1
7Networks_RH_Cont_pCun_1
7Networks_RH_Default_Par_1
7Networks_RH_Default_Temp_1
7Networks_RH_Default_Temp_2
7Networks_RH_Default_Temp_3
7Networks_RH_Default_PFCv_1
7Networks_RH_Default_PFCv_2
7Networks_RH_Default_PFCdPFCm_1
7Networks_RH_Default_PFCdPFCm_2
7Networks_RH_Default_PFCdPFCm_3
7Networks_RH_Default_pCunPCC_1
7Networks_RH_Default_pCunPCC_2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end