# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^'(.*?)'.*/$1/gm;t' <<< "'contentX' is not one of ['Illumina NovaSeq 6000', 'Other', 'Ion Torrent PGM', 'Illumina HiSeq X Ten', 'Illumina HiSeq 4000', 'Illumina NextSeq', 'Complete Genomics', 'Illumina Genome Analyzer II']"