re = /^'(.*?)'.*/m
str = '\'contentX\' is not one of [\'Illumina NovaSeq 6000\', \'Other\', \'Ion Torrent PGM\', \'Illumina HiSeq X Ten\', \'Illumina HiSeq 4000\', \'Illumina NextSeq\', \'Complete Genomics\', \'Illumina Genome Analyzer II\']'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result