use strict;
my $str = '<img src="/name">
<a href="javascript:void">some url</a>
<a href="https://convertkit.com">URL</a>
<img src=x onerror="alert(document.domain)">
<img src=x onerror=" alert(document.domain) ">
<img src=x
onerror="alert(document.domain)"
>
<img src=x onerror=alert(document.domain)>
<button form="form1" formaction="javascript:alert(1)">Submit</button>
<form action=""></form>
<button onclick="hacked()">Hack</button>
<a href="https://convertkit.com/about?utm_content=bazard">click men</a>
<div>onmouseover=alert(1)</div>
<div> onmouseover=alert(1) </div>';
my $regex = qr/(?<=<[^>]*)(?<=\s)(on\w+|formaction|action)=["']?(.*?)["']?(?=[\n>])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}