import re
regex = re.compile(r"(?<=<[^>]*)(?<=\s)(on\w+|formaction|action)=[\"']?(.*?)[\"']?(?=[\n>])", flags=re.MULTILINE)
test_str = ("<img src=\"/name\">\n"
"<a href=\"javascript:void\">some url</a>\n"
"<a href=\"https://convertkit.com\">URL</a>\n"
"<img src=x onerror=\"alert(document.domain)\">\n"
"<img src=x onerror=\" alert(document.domain) \">\n"
"<img src=x\n"
"onerror=\"alert(document.domain)\"\n"
">\n"
"<img src=x onerror=alert(document.domain)>\n"
"<button form=\"form1\" formaction=\"javascript:alert(1)\">Submit</button>\n"
"<form action=\"\"></form>\n"
"<button onclick=\"hacked()\">Hack</button>\n"
"<a href=\"https://convertkit.com/about?utm_content=bazard\">click men</a>\n"
"<div>onmouseover=alert(1)</div>\n"
"<div> onmouseover=alert(1) </div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")