import Foundation
let pattern = #"(?<=<[^>]*)(?<=\s)(on\w+|formaction|action)=["']?(.*?)["']?(?=[\n>])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<img src="/name">
<a href="javascript:void">some url</a>
<a href="https://convertkit.com">URL</a>
<img src=x onerror="alert(document.domain)">
<img src=x onerror=" alert(document.domain) ">
<img src=x
onerror="alert(document.domain)"
>
<img src=x onerror=alert(document.domain)>
<button form="form1" formaction="javascript:alert(1)">Submit</button>
<form action=""></form>
<button onclick="hacked()">Hack</button>
<a href="https://convertkit.com/about?utm_content=bazard">click men</a>
<div>onmouseover=alert(1)</div>
<div> onmouseover=alert(1) </div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)