import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[\\b\\B]?(?:(?P<EngDate>[a-zA-Z]+ )?(?P<Date0>(?:\\d{1,2}(?=[ ,./-])|\\d{4})?)\\.??(?(2),?)(?P<d_sep>[ ,./-])?(?:(?P<Date1>[^\\W\\d_]+|\\d{1,2})(?(3)(?P=d_sep)))?(?P<Date2>\\d{4}|\\d{2})?(?!\\:|\\.|\\d))|(?:(?<!\\d)(?P<Hours>[0-2]?\\d)[:\\.](?P<Minutes>[0-5]\\d)(?:[:\\.](?P<Seconds>[0-5]\\d))?(?:[,\\.](?P<SenodsFraction>\\d{6}|\\d{3}))?(?: \\w\\W)?(?:(?:[\\. \\w+]?(?:(?P<Z>(?:[a-zA-Z]{3,5})|(?:[+-]\\d\\d?:?[0,3,4]?[0,5]?))|(?P<s>PD|[apmAPM]{2})))+)?))";
final String string = "Mar 22 12:11:07 CET 1999\n"
+ "Mar 22 05:10:07 CET 1999";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}