const regex = new RegExp('(?:[\\b\\B]?(?:(?P<EngDate>[a-zA-Z]+ )?(?P<Date0>(?:\\d{1,2}(?=[ ,./-])|\\d{4})?)\\.??(?(2),?)(?P<d_sep>[ ,./-])?(?:(?P<Date1>[^\\W\\d_]+|\\d{1,2})(?(3)(?P=d_sep)))?(?P<Date2>\\d{4}|\\d{2})?(?!\\:|\\.|\\d))|(?:(?<!\\d)(?P<Hours>[0-2]?\\d)[:\\.](?P<Minutes>[0-5]\\d)(?:[:\\.](?P<Seconds>[0-5]\\d))?(?:[,\\.](?P<SenodsFraction>\\d{6}|\\d{3}))?(?: \\w\\W)?(?:(?:[\\. \\w+]?(?:(?P<Z>(?:[a-zA-Z]{3,5})|(?:[+-]\\d\\d?:?[0,3,4]?[0,5]?))|(?P<s>PD|[apmAPM]{2})))+)?))', 'g')
const str = `Mar 22 12:11:07 CET 1999
Mar 22 05:10:07 CET 1999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}