use strict;
my $str = 'Mar 22 12:11:07 CET 1999
Mar 22 05:10:07 CET 1999';
my $regex = qr/(?:[\b\B]?(?:(?P<EngDate>[a-zA-Z]+ )?(?P<Date0>(?:\d{1,2}(?=[ ,./-])|\d{4})?)\.??(?(2),?)(?P<d_sep>[ ,./-])?(?:(?P<Date1>[^\W\d_]+|\d{1,2})(?(3)(?P=d_sep)))?(?P<Date2>\d{4}|\d{2})?(?!\:|\.|\d))|(?:(?<!\d)(?P<Hours>[0-2]?\d)[:\.](?P<Minutes>[0-5]\d)(?:[:\.](?P<Seconds>[0-5]\d))?(?:[,\.](?P<SenodsFraction>\d{6}|\d{3}))?(?: \w\W)?(?:(?:[\. \w+]?(?:(?P<Z>(?:[a-zA-Z]{3,5})|(?:[+-]\d\d?:?[0,3,4]?[0,5]?))|(?P<s>PD|[apmAPM]{2})))+)?))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}