const regex = /\b(java|jsp?|web|xml)=([^;\s]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(java|jsp?|web|xml)=([^;\\s]+)', 'gm')
const str = `java=10514;js=237;jsp=3995;web=5;xml=42`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}