$re = '/\b(java|jsp?|web|xml)=([^;\s]+)/m';
$str = 'java=10514;js=237;jsp=3995;web=5;xml=42';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);