re = /\b(java|jsp?|web|xml)=([^;\s]+)/m
str = 'java=10514;js=237;jsp=3995;web=5;xml=42'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end