$re = '/(?<=(?<!`)`)[^`\r\n]+(?=`(?!`))|(?<=(?<!`)```)[^`\r\n]+(?=```(?!`))/m';
$str = '`ab`
ab `cd` ef
`ab``
```efg```
ab```efg``` hi
```cd``
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);