re = /(?<=(?<!`)`)[^`\r\n]+(?=`(?!`))|(?<=(?<!`)```)[^`\r\n]+(?=```(?!`))/m
str = '`ab`
ab `cd` ef
`ab``
```efg```
ab```efg``` hi
```cd``
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end