import re
regex = re.compile(r"(?<=(?<!`)`)[^`\r\n]+(?=`(?!`))|(?<=(?<!`)```)[^`\r\n]+(?=```(?!`))", flags=re.MULTILINE)
test_str = ("`ab`\n"
"ab `cd` ef\n"
"`ab``\n"
"```efg```\n"
"ab```efg``` hi\n"
"```cd``\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")