const regex = /^(\p{L}+)\d+$/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\p{L}+)\\d+$', 'gmu')
const str = `See https://stackoverflow.com/questions/77054226/regex-help-to-capture-string-except-last-2-letters-in-pcre
- Enabling the "u" flag for unicode will let you work on strings with emojis, special accentued chars, etc.
^ means "starting with"
\$ means "ending with"
\\p{L} will match any letter in any language. It will match "a", "é", "ñ" but not "!" or ","
\\d will match any digit
If you strictly want to match only strings ending with two digits then replace \\d+ by \\d{2}
Should match:
test01
test012
abcd02
Should NOT match:
###05
12345
Hello`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}