// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)^(\p{L}+)\d+$").unwrap();
let string = "See https://stackoverflow.com/questions/77054226/regex-help-to-capture-string-except-last-2-letters-in-pcre
- Enabling the \"u\" flag for unicode will let you work on strings with emojis, special accentued chars, etc.
^ means \"starting with\"
$ means \"ending with\"
\\p{L} will match any letter in any language. It will match \"a\", \"é\", \"ñ\" but not \"!\" or \",\"
\\d will match any digit
If you strictly want to match only strings ending with two digits then replace \\d+ by \\d{2}
Should match:
test01
test012
abcd02
Should NOT match:
###05
12345
Hello";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}