# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\p{L}+)\d+$"
test_str = ("See https://stackoverflow.com/questions/77054226/regex-help-to-capture-string-except-last-2-letters-in-pcre\n\n"
"- Enabling the \"u\" flag for unicode will let you work on strings with emojis, special accentued chars, etc.\n"
"^ means \"starting with\"\n"
"$ means \"ending with\"\n"
"\\p{L} will match any letter in any language. It will match \"a\", \"é\", \"ñ\" but not \"!\" or \",\"\n"
"\\d will match any digit\n"
"If you strictly want to match only strings ending with two digits then replace \\d+ by \\d{2}\n\n"
"Should match:\n"
"test01\n"
"test012\n"
"abcd02\n\n"
"Should NOT match:\n"
"###05\n"
"12345\n"
"Hello")
matches = re.finditer(regex, test_str, re.MULTILINE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.