use strict;
my $str = '2019/10/09 10:49:57 RC A [0001] SA_SESSION_4DADFC2D076747410158D882465E0A93DE45 - admin - Administrator disconnected, class R C';
my $regex = qr/^(.*)\s+(RC).*(SA_SESSION\S*)\s+-\s+(\S*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}