// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*)\s+(RC).*(SA_SESSION\S*)\s+-\s+(\S*)").unwrap();
let string = "2019/10/09 10:49:57 RC A [0001] SA_SESSION_4DADFC2D076747410158D882465E0A93DE45 - admin - Administrator disconnected, class R C";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}