re = /^(.*)\s+(RC).*(SA_SESSION\S*)\s+-\s+(\S*)/m
str = '2019/10/09 10:49:57 RC A [0001] SA_SESSION_4DADFC2D076747410158D882465E0A93DE45 - admin - Administrator disconnected, class R C'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end