import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "var\\((-{2}\\w+-?-?\\w+)\\)";
final String string = "<div data-color=\"var(--secondary)\" data-color-end=\"var(--brand-primary)\">\n"
+ "<span class=\"icon icon__centered\">\n"
+ "<i class=\"fal fa-paper-plane\" aria-hidden=\"true\"></i>\n"
+ "</span>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}