const regex = /var\((-{2}\w+-?-?\w+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('var\\((-{2}\\w+-?-?\\w+)\\)', 'gm')
const str = `<div data-color="var(--secondary)" data-color-end="var(--brand-primary)">
<span class="icon icon__centered">
<i class="fal fa-paper-plane" aria-hidden="true"></i>
</span>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}