// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)var\((-{2}\w+-?-?\w+)\)").unwrap();
let string = "<div data-color=\"var(--secondary)\" data-color-end=\"var(--brand-primary)\">
<span class=\"icon icon__centered\">
<i class=\"fal fa-paper-plane\" aria-hidden=\"true\"></i>
</span>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}