package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(?<exitingN>N)|((?<exitingF>[UMTREL]{1})(?<exitingNumber>[0-9]+)))-((?<enteringB>B)|(?:(?<enteringF>[UMTREL]{1})(?<enteringNumber>[0-9]+)))`)
var str = `N-U0 U0-M1
M1-T9 T9-R10 R10-E19
E19-L100 L100-B`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}